2.1. Installation

Note

If you just want to use Bugzilla, you do not need to install it. None of this chapter is relevant to you. Ask your Bugzilla administrator for the URL to access it from your web browser.

The Bugzilla server software is usually installed on Linux or Solaris. If you are installing on another OS, check Section 2.5 before you start your installation to see if there are any special instructions.

This guide assumes that you have administrative access to the Bugzilla machine. It not possible to install and run Bugzilla itself without administrative access except in the very unlikely event that every single prerequisite is already installed.

Warning

The installation process may make your machine insecure for short periods of time. Make sure there is a firewall between you and the Internet.

You are strongly recommended to make a backup of your system before installing Bugzilla (and at regular intervals thereafter :-).

In outline, the installation proceeds as follows:

  1. Install Perl (5.8.1 or above)

  2. Install a Database Engine

  3. Install a Webserver

  4. Install Bugzilla

  5. Install Perl modules

  6. Install a Mail Transfer Agent (Sendmail 8.7 or above, or an MTA that is Sendmail-compatible with at least this version)

  7. Configure all of the above.

2.1.1. Perl

Installed Version Test:
perl -v

Any machine that doesn't have Perl on it is a sad machine indeed. If you don't have it and your OS doesn't provide official packages, visit http://www.perl.com. Although Bugzilla runs with Perl 5.8.1, it's a good idea to be using the latest stable version.

2.1.2. Database Engine

Bugzilla supports MySQL, PostgreSQL and Oracle as database servers. You only require one of these systems to make use of Bugzilla.

2.1.2.1. MySQL

Installed Version Test:
mysql -V

If you don't have it and your OS doesn't provide official packages, visit http://www.mysql.com. You need MySQL version 4.1.2 or higher.

Note

Many of the binary versions of MySQL store their data files in /var. On some Unix systems, this is part of a smaller root partition, and may not have room for your bug database. To change the data directory, you have to build MySQL from source yourself, and set it as an option to configure.

If you install from something other than a packaging/installation system, such as .rpm (Redhat Package), .deb (Debian Package), .exe (Windows Executable), or .msi (Microsoft Installer), make sure the MySQL server is started when the machine boots.

2.1.2.2. PostgreSQL

Installed Version Test:
psql -V

If you don't have it and your OS doesn't provide official packages, visit http://www.postgresql.org/. You need PostgreSQL version 8.00.0000 or higher.

If you install from something other than a packaging/installation system, such as .rpm (Redhat Package), .deb (Debian Package), .exe (Windows Executable), or .msi (Microsoft Installer), make sure the PostgreSQL server is started when the machine boots.

2.1.2.3. Oracle

Installed Version Test:
select * from v$version
(you first have to log in into your DB)

If you don't have it and your OS doesn't provide official packages, visit http://www.oracle.com/. You need Oracle version 10.02.0 or higher.

If you install from something other than a packaging/installation system, such as .rpm (Redhat Package), .deb (Debian Package), .exe (Windows Executable), or .msi (Microsoft Installer), make sure the Oracle server is started when the machine boots.

2.1.3. Web Server

Installed Version Test: view the default welcome page at http://<your-machine>/

You have freedom of choice here, pretty much any web server that is capable of running CGI scripts will work. However, we strongly recommend using the Apache web server (either 1.3.x or 2.x), and the installation instructions usually assume you are using it. If you have got Bugzilla working using another web server, please share your experiences with us by filing a bug in Bugzilla Documentation.

If you don't have Apache and your OS doesn't provide official packages, visit http://httpd.apache.org/.

2.1.4. Bugzilla

Download a Bugzilla tarball (or check it out from CVS) and place it in a suitable directory, accessible by the default web server user (probably "apache" or "www"). Good locations are either directly in the web server's document directories or in /usr/local with a symbolic link to the web server's document directories or an alias in the web server's configuration.

Caution

The default Bugzilla distribution is NOT designed to be placed in a cgi-bin directory. This includes any directory which is configured using the ScriptAlias directive of Apache.

Once all the files are in a web accessible directory, make that directory writable by your web server's user. This is a temporary step until you run the checksetup.pl script, which locks down your installation.

2.1.5. Perl Modules

Bugzilla's installation process is based on a script called checksetup.pl. The first thing it checks is whether you have appropriate versions of all the required Perl modules. The aim of this section is to pass this check. When it passes, proceed to Section 2.2.

At this point, you need to su to root. You should remain as root until the end of the install. To check you have the required modules, run:

bash# ./checksetup.pl --check-modules

checksetup.pl will print out a list of the required and optional Perl modules, together with the versions (if any) installed on your machine. The list of required modules is reasonably long; however, you may already have several of them installed.

The preferred way of installing Perl modules is to use the install-module.pl script on Unix, or PPM on Windows (see Section 2.5.1.2). If for some reason you need to install the Perl modules manually, see Appendix C. For instance, on Unix:

bash# perl install-module.pl <modulename>

Tip

Many people complain that Perl modules will not install for them. Most times, the error messages complain that they are missing a file in "@INC". Virtually every time, this error is due to permissions being set too restrictively for you to compile Perl modules or not having the necessary Perl development libraries installed on your system. Consult your local UNIX systems administrator for help solving these permissions issues; if you are the local UNIX sysadmin, please consult the newsgroup/mailing list for further assistance or hire someone to help you out.

Note

If you are using a package-based system, and attempting to install the Perl modules from CPAN, you may need to install the "development" packages for MySQL and GD before attempting to install the related Perl modules. The names of these packages will vary depending on the specific distribution you are using, but are often called <packagename>-devel.

Here is a complete list of modules and their minimum versions. Some modules have special installation notes, which follow.

Required Perl modules:

  1. CGI 3.21

  2. Date::Format (2.21)

  3. DBI (1.41)

  4. DBD::mysql (4.00) if using MySQL

  5. DBD::Pg (1.45) if using PostgreSQL

  6. DBD::Oracle (1.19) if using Oracle

  7. Template (2.22)

  8. Email::Send (2.00)

  9. Email::MIME::Modifier (1.442)

Optional Perl modules:

  1. GD (1.20) for bug charting

  2. Template::Plugin::GD::Image (1.20) for Graphical Reports

  3. Chart::Base (1.0) for bug charting

  4. GD::Graph (any) for bug charting

  5. GD::Text (any) for bug charting

  6. XML::Twig (any) for bug import/export

  7. MIME::Parser (5.406) for bug import/export

  8. LWP::UserAgent (any) for Automatic Update Notifications

  9. PatchReader (0.9.4) for pretty HTML view of patches

  10. Image::Magick (any) for converting BMP image attachments to PNG

  11. Net::LDAP (any) for LDAP Authentication

  12. Authen::Radius (any) for RADIUS Authentication

  13. SOAP::Lite (0.710.06) for the web service interface

  14. HTML::Parser (3.40) for More HTML in Product/Group Descriptions

  15. HTML::Scrubber (any) for More HTML in Product/Group Descriptions

  16. Email::MIME::Attachment::Stripper (any) for Inbound Email

  17. Email::Reply (any) for Inbound Email

  18. mod_perl2 (1.999022) for mod_perl

2.1.5.1. DBD::mysql

The installation process will ask you a few questions about the desired compilation target and your MySQL installation. For most of the questions the provided default will be adequate, but when asked if your desired target is the MySQL or mSQL packages, you should select the MySQL-related ones. Later you will be asked if you wish to provide backwards compatibility with the older MySQL packages; you should answer YES to this question. The default is NO.

A host of 'localhost' should be fine. A testing user of 'test', with a null password, should have sufficient access to run tests on the 'test' database which MySQL creates upon installation.

2.1.5.2. Template Toolkit (2.22)

When you install Template Toolkit, you'll get asked various questions about features to enable. The defaults are fine, except that it is recommended you use the high speed XS Stash of the Template Toolkit, in order to achieve best performance.

2.1.5.3. GD (1.20)

The GD module is only required if you want graphical reports.

Note

The Perl GD module requires some other libraries that may or may not be installed on your system, including libpng and libgd. The full requirements are listed in the Perl GD module README. If compiling GD fails, it's probably because you're missing a required library.

Tip

The version of the GD module you need is very closely tied to the libgd version installed on your system. If you have a version 1.x of libgd the 2.x versions of the GD module won't work for you.

2.1.5.4. Chart::Base (1.0)

The Chart::Base module is only required if you want graphical reports. Note that earlier versions that 0.99c used GIFs, which are no longer supported by the latest versions of GD.

2.1.5.5. GD::Graph (any)

The GD::Graph module is only required if you want graphical reports.

2.1.5.6. GD::Text (any)

The GD::Text module is only required if you want graphical reports.

2.1.5.7. XML::Twig (any)

The XML::Twig module is only required if you want to import XML bugs using the importxml.pl script. This is required to use Bugzilla's "move bugs" feature; you may also want to use it for migrating from another bug database.

2.1.5.8. SOAP::Lite (0.710.06)

Installing SOAP::Lite enables your Bugzilla installation to be accessible at a standardized Web Service interface (SOAP/XML-RPC) by third-party applications via HTTP(S).

2.1.5.9. PatchReader (0.9.4)

The PatchReader module is only required if you want to use Patch Viewer, a Bugzilla feature to show code patches in your web browser in a more readable form.

2.1.6. Mail Transfer Agent (MTA)

Bugzilla is dependent on the availability of an e-mail system for its user authentication and for other tasks.

Note

This is not entirely true. It is possible to completely disable email sending, or to have Bugzilla store email messages in a file instead of sending them. However, this is mainly intended for testing, as disabling or diverting email on a production machine would mean that users could miss important events (such as bug changes or the creation of new accounts).

For more information, see the "mail_delivery_method" parameter in Section 3.1.

On Linux, any Sendmail-compatible MTA (Mail Transfer Agent) will suffice. Sendmail, Postfix, qmail and Exim are examples of common MTAs. Sendmail is the original Unix MTA, but the others are easier to configure, and therefore many people replace Sendmail with Postfix or Exim. They are drop-in replacements, so Bugzilla will not distinguish between them.

If you are using Sendmail, version 8.7 or higher is required. If you are using a Sendmail-compatible MTA, it must be congruent with at least version 8.7 of Sendmail.

Consult the manual for the specific MTA you choose for detailed installation instructions. Each of these programs will have their own configuration files where you must configure certain parameters to ensure that the mail is delivered properly. They are implemented as services, and you should ensure that the MTA is in the auto-start list of services for the machine.

If a simple mail sent with the command-line 'mail' program succeeds, then Bugzilla should also be fine.

2.1.7. Installing Bugzilla on mod_perl

It is now possible to run the Bugzilla software under mod_perl on Apache. mod_perl has some additional requirements to that of running Bugzilla under mod_cgi (the standard and previous way).

Bugzilla requires mod_perl to be installed, which can be obtained from http://perl.apache.org - Bugzilla requires version 1.999022 (AKA 2.0.0-RC5) to be installed.